2 Tracks in 2 Days! Part 1 of 2

Insane weekend! The plan was to run Sat 6/12 with NASA @ BlackHawk Farms then drive the 2.5 hrs to run with Redline Time Attack @ Autobahn on Sun 6/13. Short story; it was accomplished but not without some cumbersome issues!

We arrived @ Blackhawk about 11pm Friday night. Sat morning I ran the car on street tires to get a practice session in, got a rain session in then went to mount up new Hoosiers. At about 11am I discovered a stripped front wheel stud. I seeked out all the other Evo’s at the track along with calling parts stores in both IL and Wisconsin for parts – notta. I was able to locate 2 stock length studs in Wisconsin and thought I could make one work, so I sent my finance’ on a parts run. While she was out, I sourced an old stock stud off a 2G Eclipse (thx racer145!). I dismantled everything (sweating profusely) and although the old stud didn’t fit tightly at all, I figured I could make it work with some luck and pressure. I bolted everything back up about the time my parts hottie got back. At this point the our dog was throwing up since it was too hot; so my attention wasn’t at 100%.

Missing only 1 session, I got in the car to hit the 4th session and it felt like the brakes were stuck on. So I hopped out and tore back into it finding that I had put the spacer on the wrong side of the caliper bolt (spacer for front air cooling ducts). So while apart, I switched out the old stud (which simply fell out w/o force) for a new shiny one and tightened everything down. With only 1 session left and my only official laps in a slight rain I was sitting in 3rd of 3 cars in class I think.

I lined up about 15min early for the last session of the day (anxious). My warm up lap I hammered the throttle and popped an intercooler hose clamp that I had borrowed from a friend thinking it would be a better clamp – but no dice. Knowing the session is just 15min long I feverishly limped into the pits and switched back in a hose clamp and prayed I could get just 1 clean lap in. Turns out I had time for 2! With fresh R6’s I got last November and no time to heat cycle then I drove about 7/10’s and took 1st place and the track record with my first hot lap! My 2nd lap was about the same but with some traffic so I backed off looking for space to get another run at a good one – but the checkered was out and the day was done.
Crazy! After wards I checked my tire temps and I had 44/45 in the fronts so I was waaay off. Although I didn’t even run as fast as I did last year here in a lower class, I was happy with the win and new record. I didn’t get to run my 100octane tune and I was about 130lbs over minimum weight. So, I left a LOT of time out on the track. But, nothing was broke, the car was running great (thanks to my AMS Performance tune and AMSOIL fluids), and I had another event on Sunday!

We then packed things up, I showered, and we started on the 2.5 hr trip towards Joliet for the Redline event on Sunday. Eta was about 8:30pm.